Configuration d'un serveur RCS [Résolu]

Voir le sujet précédent Voir le sujet suivant Aller en bas

Configuration d'un serveur RCS [Résolu]

Message par Giuliani le Mer 25 Juin - 22:32

Bonjour à tous,
C'est cool, il n'y avait pas encore de sujet de ce type ^^

Je commence prochainement les alpha-tests de mon projet avec RCS mais j'ai quelques soucis de connexion entre le client et le serveur.
Pour le moment, je réalise des tests sur mon PC perso, et je suis chez Free (Freebox V6).
Dans un 1er temps j'ai essayé de connecter mon PC à mon second PC en LAN. Mais je me suis souvenu avoir lu quelque part que quelqu’un avait également des soucis du coup j'ai lâché l'affaire et j'ai envoyé le client à des potes à l’extérieur, même constat, ils n'arrivent pas à se connecter. "Unvalid Host Name"
Après 2 heures à tout essayer, sans succès...

Détail de la configuration serveur:
Je suis sur la Freebox V6.
J'ai mon adresse IP 82.240.etc... et mon adresse locale 192.168.0.14.
Le serveur DHCP server est actif, j'ai également essayé de travailler avec No-ip.com mais sans succès... J'ai attribué à mon IP local un nom de domaine, j'ai modifié le nom de l'hôte dans le fichier du client, et nom d'hôte incorrect...
J'ai d'abord ouvert les ports 25000 de ma Feebox en TCP, puis en UDP (comme le demande Solstar) puis en UDP/TCP.
J'ai créé un baux DHCP permanent pour mon PC 192.168.0.14 en me basant sur l'adresse MAC de ce dernier.
Mon firewall est inactif.
J'ai tenté un ping depuis mon second PC sur l'adresse 82.240.etc... Pas de réponse.
Chaque fois que je réalise un test, je modifie le nom de l'hôte dans Hosts.dat

La configuration de ma freebox en image:


Là, je pense avoir tout essayé, je ne sais plus trop quoi faire...

MAJ:

Victoire!

Après 2h de tests avec un pote qui touche en réseau (chez Airbus), ça marche!
3 clients connectés sur mon PC en local ça tourne nickel.

_ D'abord ma Freebox (pour une raison inconnue) n'était pas "pingable" depuis l'extérieur (c'est réglé)
_ Ensuite j'ai paramétré ma carte réseau en IP fixe 192.168.0.21 hors DHCP (qui s'étend de 192.168.0.10 à 192.168.0.20)
_ J'ai redirigé les ports vers cette adresse locale
_ J'ai ensuite ouvert le port 25000 en TCP (dans un 1er temps) mais ça ne fonctionnait qu'en local (2 pc chez moi)
_ Et on a ensuite ouvert le port 25000 en UDP (malgré sa réticence), et les clients ont pu se connecter depuis l'extérieur.
_ Dans le fichier Hosts.dat, ça fonctionne avec l'adresse de la box (82.240.etc..). (Et pour ceux qui ont un second poste à la maison, faut mettre l'IP locale (192.168.0.21)).


Maintenant de l'avis de mon pote, c'est programmé à la porcho...
Le port UDP qui ne sert qu'en sortie... C'est fait à l'arrache, mais je m'en fous tant que ça marche Very Happy
avatar
Giuliani
Admin

Messages : 216
Points : 361
Date d'inscription : 25/06/2014
Age : 38
Localisation : Toulouse

http://realmcrafter.frbb.net

Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum